The scheduled maintenance has been successfully completed. All services for our users from Canadian schools are now fully operational. If you experience any issues, please clear your cache or contact our support team. Thank you for your patience!
Posted Aug 27, 2025 - 14:02 EDT
Monitoring
The scheduled maintenance for our Canadian school service migration has begun. Services for users at impacted Canadian schools are currently unavailable. Thank you for your understanding!
Posted Aug 27, 2025 - 10:07 EDT
Investigating
We will be performing scheduled maintenance to migrate users from Canadian schools to our dedicated Canadian infrastructure. During this time, services for affected users will be unavailable. We appreciate your patience as we work to improve our platform.